[MediaWiki-l] Potential breaking change for VisualEditor installations in upcoming Parsoid release (v0.9.0)

Subramanya Sastry ssastry at wikimedia.org
Fri Mar 23 19:40:28 UTC 2018


Hello everyone,

We are releasing the next version of the Parsoid deb and npm packages 
(v0.9.0) later today. There is one significant change in this release 
that might affect some VisualEditor installations. This version of 
Parsoid wraps sections in <section> tags and bumps the HTML version to 
1.6.1. However, VisualEditor installations older than Dec 12, 2017 are 
not compatible with this section wrapped output.

In order to prevent silent failures, Parsoid will do a hard fail and 
reject parse requests with a HTTP 406 when it receives a version string 
smaller than 1.6.0 (which VE before Dec 12, 2017 would issue). VE will 
then popup the following error: "Error loading data from server: 
apierror-visualeditor-docserver-http: HTTP 406. Would you like to 
retry?" Retries won't help in this scenario.

Knowing this, you have a couple of options:

  * Not upgrade Parsoid. If you upgrade Parsoid without reading this
    notice and later stumble on this (which we'll also add to the
    Parsoid releases page), you have the option of downgrading your
    Parsoid install by downloading an older deb package from
    https://people.wikimedia.org/~ssastry/parsoid/debs/
  * If you choose to upgrade Parsoid and your VE installation is from
    before Dec 12, 2017 (which is probably most of you), the recommended
    solution is to upgrade your VisualEditor installation as well.

If for some reason you really really need to upgrade Parsoid but cannot 
upgrade VisualEditor, contact us on IRC in #mediawiki-parsoid to ask us 
how you can do that.

Subbu.

(on behalf of Parsoid developers).



More information about the MediaWiki-l mailing list