[MediaWiki-l] Keeps saying A LocalSettings.php file has been detected.

Andrius D. Ilgunas andrius at ilgunas.net
Thu Apr 27 15:47:56 UTC 2017


But I don't *HAVE* a LocalSetting.php file yet. This happens either when I
do a "git clone/composer update" install, or a vanilla "tarball/extract"
install. I hit up http://mysite.dev/mw-config/index.php, and it dutifully
reports that:

MediaWiki 1.28.1

LocalSettings.php not found.

Please complete the installation <http://mysite.dev/mw-config/index.php> and
download LocalSettings.php.

But on the page following it errors out with:

A LocalSettings.php file has been detected. To upgrade this installation,
please enter the value of $wgUpgradeKey in the box below. You will find it
in LocalSettings.php.


Installer be crazy.

I've cleared my cache, used a different browser, erased the ~/.composer
directory, deleted the directory/tried again and various combinations of
trying to "reset" this, but I'm still prompted with the error.

Occasionally, though, I run across this error too:

*Fatal error*: Class 'ComposerAutoloaderInit_mediawiki_vendor' not found in
*/usr/local/www/wiki/vendor/autoload.php* on line *7*


Does anyone have an idea of what might be causing this?

--
Andrius


More information about the MediaWiki-l mailing list