[MediaWiki-l] Moved site providers and now my URLs are /wiki/index.php?title=page

Brian Wolff bawolff at gmail.com
Fri Sep 30 20:07:29 UTC 2016


Usually this means that mediawiki detects the new server as not supporting
PATH INFO (usually deoends on the combination of server software and which
php sapi is in use), so it cannot use the automatic short url setup. In
such a case you usually need to setup rewrite rules to make it work,
although you can also try adjusting $wgUsePathInfo to override the feature
support autodetection if you think path info is really supported.

--
Bawolff

On Friday, September 30, 2016, Richard <legalize at xmission.com> wrote:
> Hi,
>
> I just relocated my site by changing hosting providers.  I set up my
> old site some time ago, but I thought I migrated everything to the
> new site.  On the old site, I could reference pages by the URL
> /wiki/index.php/<page>, such as
> http://terminals-wiki.org/wiki/index.php/Category:DEC
>
> Now those URLs aren't working and when I browse the wiki, the URLs
> are all of the form
> http://terminals-wiki.org/wiki/index.php?title=Category:DEC
>
> From looking at mediawiki documentation, it seems the preferred way
> to make the URLs work again is to use .htaccess and a rewrite rule?
>
> Am I headed in the right direction?
>
> Thanks in advance
> --
> "The Direct3D Graphics Pipeline" free book <
http://tinyurl.com/d3d-pipeline>
>      The Computer Graphics Museum <http://ComputerGraphicsMuseum.org>
>          The Terminals Wiki <http://terminals-wiki.org>
>   Legalize Adulthood! (my blog) <http://LegalizeAdulthood.wordpress.com>
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>


More information about the MediaWiki-l mailing list