[MediaWiki-l] Mediawiki 1.27 php missmatch message

John Foster jfoster81747 at gmail.com
Thu Feb 4 17:38:47 UTC 2016


I'm experimenting with the new 1.27 mediawiki and have it installed on a
working LAMP system ubuntu. I am getting this apache error message when I
try to start the server:

[Thu Feb 04 10:03:24.654584 2016] [:error] [pid 26404] [client
51.255.65.68:27433] PHP Fatal error:  require_once(): Failed opening
required '/var/www/html/includes/PHPVersionCheck.php'
(include_path='.:/usr/share/php:/usr/share/pear') in
/var/www/html/index.php on line 36

I see that the there is no longer a index.php5 file in the start up and the
index.php file is vastly different than 1.25.2 mediawiki.

FYI: I also am running and have verified that it works Php7. Just need to
figure out how to configure the mediawiki1.27 to use it.  I have also run
composer update and only get a depreciation error warning on constraints.
That should not stop the mediawiki from running. It also did not run and
gave the exact same error with php5.6.2 I thought the upgrade would fix it.
But did not.

Any tips on what to do.

Thanks!

John


More information about the MediaWiki-l mailing list