[MediaWiki-l] What PHP version do you use?

Bartosz Dziewoński matma.rex at gmail.com
Tue Dec 8 20:15:49 UTC 2015


On 2015-12-08 21:10, Mickey Feldman wrote:
> We were (are still) running MW 1.21.1 with PHP 5.3.29. Our host upgraded
> to PHP 5.5 as default, and will soon discontinue support for PHP5.3.
>
> MW 1.21 was advertised as "requires PHP5.3 or higher". I took that to
> mean PHP5.5 would not cause any problems.
>
> As soon as the switchover happened, we had a screen full of error
> messages rather than wiki pages. I set the .htaccess to use PHP 5.3, and
> we now have a functioning wiki again.

The last point release of MediaWiki 1.21, before that branch stopped 
receiving patches, was 1.21.11. It's likely that one of the patches 
after 1.21.1 fixed your problems.
(https://phabricator.wikimedia.org/T60640 is a big one I recall from 
that time.)

-- 
Bartosz Dziewoński



More information about the MediaWiki-l mailing list