[MediaWiki-l] [Wikitech-l] Requiring PHP >= 5.3.3 for MediaWiki core

James Forrester jforrester at wikimedia.org
Fri Oct 24 16:31:05 UTC 2014


On 24 October 2014 08:41, Chad <innocentkiller at gmail.com> wrote:

> On Fri, Oct 24, 2014 at 8:12 AM, James Forrester <jforrester at wikimedia.org
> >
> wrote:
>
> > On 23 October 2014 18:39, Legoktm <legoktm.wikipedia at gmail.com> wrote:
> >
> > > Hi,
> > >
> > > As part of the librarization project[1], we are planning on taking the
> > > CSSJanus library that is currently in includes/lib/ and bringing it in
> > > with composer. However, it requires PHP >=5.3.3 in its
> composer.json[2].
> > > Krinkle has stated[3] that is due to the fact that it has only been
> > > tested on 5.3.3 and higher, and it's also what travis-ci provides.
> > >
> > > After doing some research[4], it appears that we would be dropping
> > > support for Ubuntu 10.04LTS, which has security support until April
> > > 2015. MediaWiki 1.25.0 is expected to be released in May 2015.
> > >
> > > Does anyone have any objections to dropping 5.3.2 support? I've
> uploaded
> > > [5] that actually increments the required version number.
> > >
> >
> > ​I understood that the vague plan was to switch over to 5.4.x
> requirement,
> > and that we'd only waited because Wikimedia wasn't ready yet. Has this
> > changed? I know a number of people have talked about wanting to use PHP
> > traits.
> >
> >
> Yes, but that's longer term.
>

​How much longer? 1.25 is May 2015; Wikimedia's ZAP -> HAT migration is
nominally to be finished within a month…​



> This minor bump still in the 5.3.x branch I think we can do immediately.
>

​Sure, if announcing a 1.25 dependency change and then changing the change
later won't disrupt people too much.

(Copying the main MediaWiki-l list for those who don't follow wikitech-l)

​J.​
-- 
James D. Forrester
Product Manager, Editing
Wikimedia Foundation, Inc.

jforrester at wikimedia.org | @jdforrester


More information about the MediaWiki-l mailing list