[MediaWiki-l] Imgages

Steve VanSlyck s.vanslyck at spamcop.net
Tue Jan 22 01:56:23 UTC 2013


All right, here is the solution:

https://discussion.dreamhost.com/thread-127007.html

In short, there is something wrong with the .htaccess file, created to 
"Protect against bug 28235."

On 1/21/2013 20.32, Steve VanSlyck wrote:
> Don't see why not, but here is .htaccess file in the /images directory:
>
> Options -Indexes <-----Made no difference when removed.
> # Protect against bug 28235
> <IfModule rewrite_module>
>     RewriteEngine On
>     RewriteCond %{QUERY_STRING} \.[^\\/:*?\x22<>|%]+(#|\?|$) [nocase]
>     RewriteRule . - [forbidden]
> </IfModule>
>
> # Serve HTML as plaintext, don't execute SHTML
> AddType text/plain .html .htm .shtml .php
>
> # No php execution in the upload area
> php_admin_flag engine off
>
>
>
>
> On 1/21/2013 20.26, Richard wrote:
>> In article <50FDE5F7.4060007 at spamcop.net>,
>>      Steve VanSlyck <s.vanslyck at spamcop.net> writes:
>>
>>> I ask because the image does upload but won't display on the wiki and
>>> when I click the filename I am told, "You don't have permission to
>>> access /w/images/f/f0/Filename.jpg on this server." Permission of that
>>> directory is 755 and permission of that file is 644.
>>>
>>> On 1/21/2013 19.58, Steve VanSlyck wrote:
>>>> Correct permissions for the images directory?
>> Is the web server configured to serve the directory where images are
>> uploaded?
>




More information about the MediaWiki-l mailing list