[Mediawiki-l] solaris 5.9 and Mediawiki 1.17

Brion Vibber brion at pobox.com
Wed Jul 27 16:07:59 UTC 2011


On Wed, Jul 27, 2011 at 4:08 AM, Jeff Campbell <jeffc at informatics.jax.org>wrote:

> I just tried to upgrade our version of Mediawiki(1.13?) to Mediawiki
> 1.17. Everything went fine until I went to run the update.php script and
> I got this error: ld.so.1: php: fatal: relocation error: file
> /usr/local/depot/php-5.3.6/php-5.3.6         /bin/php: symbol
> xmlTextReaderGetAttribute: referenced symbol not found
> Killed
>
> I googled for some answers and it keeps pointing to libxml2 but the
> version is 2.73 and is the same as another wiki I have running on
> another server with Mediawiki 1.17. So far the only thing I can find
> different between the 2 installs is the one that is working uses Solaris
> 5.8 and the one giving the error is version 5.9. Is there a problem with
> Mediawiki 1.17/php and Solaris 5.9?
>

It sounds like your PHP installation isn't built against the same versions
of various libraries that are actually on your system -- either it can't
find libxml2, or the version of libxml2 you have has the xmlReader interface
disabled (is that possible? no idea). Unfortunately compiling PHP & libxml2
on Solaris is pretty far out of my scope, so I can't give any direct
hints...

-- brion


More information about the MediaWiki-l mailing list