[Mediawiki-l] Upgrade 1.9.3 -> 1.12.0 fails

Steve Lindemann steve at marmot.org
Tue Jun 10 20:13:47 UTC 2008


Tim Starling wrote:
> Gsandtner Michael wrote:
>> We successfully run mediawiki for a year with version 1.9.3 
>> (with an extension function defining these hooks: 
>> AutoAuthenticate, SpecialPage_initList, UserLogoutComplete).
>>
>> Now we tried to upgrade to 1.12.0. The upgrade process seemed 
>> to be OK, since the installer completed with "Installation 
>> successfull".
>> However, it does not work; the error log states:
>> PHP Fatal error:  Class 'DOMDocument' not found in 
>> /magwien/var/gondor-phpserver/html/m13wiki/includes/Preprocess
>> or_DOM.php on line 566
> 
> This is a bug in MediaWiki, and could easily be fixed by backporting 
> r34283 and releasing 1.12.1.
> 

the problem is related specificaly to v1.12.0

There is a quick fix - add to LocalSettings.php:
   $wgParserConf['preprocessorClass'] = 'Preprocessor_Hash';

The "permanent" fix is to install the 'php-xml' package and restart Apache:
     # yum -y install php-xml   (on fedora anyway)
     # service httpd restart

Actually, I found the "permanent" fix was quicker to implement than the 
quick fix 8^)  ...but I tested each and both worked (for me)

the reference is (watch out for the line wrapping):
http://www.mediawiki.org/wiki/Project:Support_desk#.28RESOLVED.29_PHP_Fatal_error:_Class_.27DOMDocument.27_not_found_in_.2Fvar.2Fwww.2Fhtml.2Fwiki.2Fincludes.2FPreprocessor_DOM.php_on_line_566

--
Steve Lindemann                         __
Network Administrator                  //\\  ASCII Ribbon Campaign
Marmot Library Network, Inc.           \\//  against HTML/RTF email,
   url: http://www.marmot.org           //\\  vCards & M$ attachments
email: mailto:steve at marmot.org
voice: +1.970.242.3331 ext 116
   fax: +1.970.245.7854





More information about the MediaWiki-l mailing list