[Mediawiki-l] Extension:Guestbook problem

John W Foster johnwfoster at verizon.net
Wed Jan 16 16:09:27 UTC 2008


On Thu, 2008-01-10 at 18:51 -0600, John W Foster wrote:
> I am trying to get "captchas" to working on my Mediawiki installation,
> to use in conjunction with a guestbook. The author of the Mediawiki
> extension, which is written in php, says that the reason that the
> 'capchas' do not work is a problem with "certain distros" installation
> of php and certain features of GD. He does not elaborate. I have a out
> of the box installation of mediawiki, php5, and everything I can find
> that has 'gd' as part of it, all installed from Debian testing and up to
> date.
> The entire system seems to be working fine with no tweaking, except this
> particular feature. Anyone here who knows php & gd or anyone with any
> experience with getting this to work. BTW: When this was installed from
> Debian etch it all worked OK including the 'capchas' when I decided to
> set up a newer system on testing it does not.
> Thanks!!
> Frosty
> 
> 
> _______________________________________________
> MediaWiki-l mailing list
> MediaWiki-l at lists.wikimedia.org
> http://lists.wikimedia.org/mailman/listinfo/mediawiki-l

Well since no one has any ideas I thought I would post this follow up
from my own efforts, in the hope that it might help someone else.
It seems that the captchas are actually working OK. The problem is that
the browser (iceweasel) that I have installed is not displaying the
artwork created by the captchas. I downloaded another php captcha called
jhfcaptcha which is self contained and may be run as a script via
Apache2 from my web site. It has exactly the same problem. It asks for
you to input the entry needed by the captcha to do its job...however
there is no box or any thing else that shows what I am supposed to type
in. I have checked the following:
GD is installed and working according to a test.php script that shows
what is going on. Php is also completely enabled and as many functions
as I can find are installed and enabled. I did notice that the
mime-decode function is not enabled. I will try that today.
In the mean time ANY IDEAS are appreciated.
I also tried from another computer using XP and IE7 and the only
difference was thate is a box with a missing image element icon in it
and you still can not see what needs to be keyed. The more I see of this
the more I think its a php issue are a graphics conversion problem.

Frosty





More information about the MediaWiki-l mailing list