[Mediawiki-l] How to debug? (Was: Several instances on one host)

Andreas Tille tillea at rki.de
Wed May 16 07:19:42 UTC 2007


Hi,

any hint how I can try to debug the problem myself if there seems to
be no answer to the question below.  I think on thinks like
    print "I'm reading source file %s in line %d"
printed to /var/log/my_mediawiki_debug.log.

Unfortunately I never used PHP and thus I need some kick start to track
down the problem.

Kind regards

         Andreas.

On Tue, 15 May 2007, Andreas Tille wrote:

> On Thu, 10 May 2007, F.D. wrote:
>
>> There's some info on wiki farms on MediaWiki.org:
>> http://www.mediawiki.org/wiki/Manual:Wiki_family
>> Maybe that helps...
>
> The hint sounds good and I tried
>
>
> <?php
>
> $callingurl = strtolower($_SERVER['REQUEST_URI']);        // identify the asking url
>
> if ( strpos( $callingurl, 'wikiFG31') ) {
>         require_once( 'LocalSettings_wikiFG31.php' );
> }
> if ( strpos( $callingurl, 'wikiWR') ) {
>         require_once( 'LocalSettings_WR.php' );
> }
> ?>
>
>
> as new LocalSettings.php for my two instances (named FG31 and WR).
> I also added
>
> Alias /wikiFG31 /var/lib/mediawiki1.9
> Alias /wikiWR   /var/lib/mediawiki1.9
>
> to my apache2 config (I'm using the Debian packaged version of
> MediaWiki 1.9.3).
>
> If I call either
>
>    http://localhost/wikiWR/    or
>    http://localhost/wikiFG31/
>
> I get
>
>    Error, Setup.php must be included from the file scope, after DefaultSettings.php
>
> as response but I have no idea what I might have missed.
> Any idea?
>
> Kind regards
>
>         Andreas.

-- 
http://fam-tille.de



More information about the MediaWiki-l mailing list