[Mediawiki-l] upgrade path

Brion Vibber brion at pobox.com
Fri Oct 27 10:27:27 UTC 2006


Emma Gottesman wrote:
> I'm running
> * MediaWiki version 1.4.0
> * PHP version 5.0.4
> * MySQL version 4.1.11
>  under Solaris 10.
> 
> What upgrade path should I use?

The file UPGRADE describes the upgrade procedure. In short: drop in the 
new files and run maintenance/update.php.

I would also recommend upgrading to a current PHP 5.1 release, 
particularly if you're running on a 64-bit platform. The old 5.0.x 
releases have known bugs on platforms where long and int are different 
sizes, which will break various bits of MediaWiki.

-- brion vibber (brion @ pobox.com)



More information about the MediaWiki-l mailing list