[Mediawiki-l] Re: Re: accents not appearing correctly

muyuubyou muyuubyou at gmail.com
Wed Feb 8 23:04:37 UTC 2006


My locale is indeed set to Chinese... because most of my users will be
Chinese. Changing the configuration in Firefox didn't work.

Great find BTW :-)

... but I guess my little problem is there to stay, since I can't change my
users' locale. Wish they fixed that in Firefox, it's almost 10% of my
visits.

To top it off, it doesn't work with locales set to latin-1 either.

Thanks a lot, Brion. I should probably mail somebody at Mozilla :D I'm
stubborn.

On 2/8/06, Brion Vibber <brion at pobox.com> wrote:
>
> muyuubyou wrote:
> > Well, about my little issue with Firefox: I just type in the URL bar,
> and no
> > cookie. Following links works (for instance, link to pages created with
> > Opera, work also under Firefox).
> >
> > For instance:
> >
> > http://someIPhere/wiki/index.php/中文
>
> In GB 18030, that's: d6 d0 ce c4
>
> > I press enter, then the URL bar turns to:
> > http://someIPhere/wiki/index.php/%C3%96%C3%90%C3%8E%C3%84
> >
> > , which is page "ÖÐÎÄ"
>
> In ISO 8859-1, that's: d6 d0 ce c4
>
> By any chance is your desktop set to a Chinese locale? It sounds like
> Firefox is
> taking the non-ASCII chars in the URL you type and encoding them as GB
> 18030.
> MediaWiki sees these unexpected non-UTF-8 characters and tries to convert
> them
> from a fallback, which is the default of ISO 8859-1 or Windows-1252.
>
> Try setting the network.standard-url.encode-utf8 hidden preference in
> Firefox to
> true, see if that fixes it. (Who knows why they haven't turned this on
> yet, it's
> been standard on even MSIE for years...)
>
> -- brion vibber (brion @ pobox.com)
>
>
>
> _______________________________________________
> MediaWiki-l mailing list
> MediaWiki-l at Wikimedia.org
> http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
>
>
>
>


More information about the MediaWiki-l mailing list