On Sun, May 29, 2011 at 6:41 PM, Ryan Lane
I'm not sure we have standards on hook names
(someone please correct
me, if this isn't the case).
In core, there certainly is no naming convention for hooks. Some are verb
phrases, some are noun phrases. I think if you're adding a hook to an
extension you should prefix it with something unlikely to conflict with a
core hook (now or in the future).
I believe some extensions do something like "ExtensionName::HookName"
but I don't think this is widely enforced.
Given that these are generic hook names, I think it is fine with the
current names and they should get that wiki pages documentation (with
the proper note that the action is currently only done by UserMerge).
Note that the hook parameters (which I haven't reviewed) should be
general enough for the target action (ie. not specific to UserMerge).