Le 16/06/13 05:27, Tyler Romeo a écrit :> So I was wondering how people would feel about adding a coding convention
for the use of is_null() in PHP code.
It's 10 times slower than doing === null, which is a bit trivial in context, but nonetheless a fact, and it's also a bit easier to read, especially when doing the inverse (i.e., doing !is_null( ... ) versus !== null). Also, there's no functional difference between the two.
That adds more bureaucracy to our code review. Just get rid ofo is_null() where it is usage significantly harm performances (such as in an often called method or a loop).