Background and older discussions: https://www.mediawiki.org/wiki/Special:Code/MediaWiki/95596 and http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/55055 related is bug https://bugzilla.wikimedia.org/show_bug.cgi?id=35121 "rename right-passwordreset to right-passwordreset-emailsent-capture-view"
Hello,
_/I want to propose a slight change in/_ * Special:PasswordReset * similar to what I proposed last year in https://www.mediawiki.org/wiki/Special:Code/MediaWiki/95596 which was then reverted in https://www.mediawiki.org/wiki/Special:Code/MediaWiki/95618 because the change was not properly justified and discussed last year.
I now suggest these changes:
1. includes/specials/SpecialPasswordReset.php
class SpecialPasswordReset extends FormSpecialPage { public function __construct() { - parent::__construct( 'PasswordReset' ); + parent::__construct( 'PasswordReset', *'special-passwordreset-access'* ); }
Because we already have "passwordreset" (right to view the password reset mail when it was sent to user) in order to avoid confusion I choose special-passwordreset-access (this should be renamed as suggested in bug35121, not topic of this mail)
2. includes/DefaultSettings.php:
+ *$wgGroupPermissions['*']['**special-passwordreset-access**'] = true;*
3. languages/MessagesEn.php:
'right-passwordreset' => 'View password reset e-mails', + *'right-special-passwordreset-access**' => 'Can access Special:PasswordReset', *
Is it possible to reach a consensus about the new right so I can submit such a change to core ? I'll be available in #mediawiki now.
Tom (Wikinaut)