Isn't it recommanded to use id rather than name to create anchors? If so, it could be a good idea to fix this. We could add the id attribute with the same value as the name attribute.
In Linker.php, line 1521 ( http://svn.wikimedia.org/doc/Linker_8php-source.html#l01521) :
public function makeHeadline( $level, $attribs, $anchor, $text, $link ) { return "<a name="$anchor"></a><h$level$attribs$link <span class="mw-headline">$text</span></h$level>"; }
(Tell me if I'm wrong.)
— Sylvain Brunerie [[w:fr:User:Delhovlyn]]