Le 04/12/12 21:24, Tyler Romeo a écrit :
Don't we have some sort of policy about an individual merging commits that he/she uploaded? Because these three changes: https://gerrit.wikimedia.org/r/36801
https://gerrit.wikimedia.org/r/36812
https://gerrit.wikimedia.org/r/36813
Were all uploaded and submitted in a matter of minutes by the same person, and each is a fix for errors in the commit before it. It kind of defeats the point of having code review in the first place.
Overall there is a lot of issues in this class such as :
- shelling out to possible non existent command (slooow) - using file locks (everytime you want a new UID it writes a file, lock it, generate the uid, unlock the file and delete it. That seems slow to me and probably not going to scale. - There is ton of code duplication when the number of bits we want should be a parameter to a generic function.
uniqid( ) will probably give you what you want without having to shell out. It is based on microtime() but you could add more entropy by passing a string prefix as first arg and true as second arg to add in pseudo random value.
Anyway that looks like a work in progress, I have submitted a change to revert the commits from master:
https://gerrit.wikimedia.org/r/36961