When list=allusers is used with auactiveusers, a property 'recenteditcount'
is returned in the result. In bug 67301[1] it was pointed out that this
property is including various other logged actions, and so should really be
named something like "recentactions".
Gerrit change 130093,[2] merged today, adds the "recentactions" result
property. "recenteditcount" is also returned for backwards compatability,
but will be removed at some point during the MediaWiki 1.25 development
cycle.
Any clients using this property should be updated to use the new property
name. The new property will be available on WMF wikis with 1.24wmf12, see
https://www.mediawiki.org/wiki/MediaWiki_1.24/Roadmap for the schedule.
[1]: https://bugzilla.wikimedia.org/show_bug.cgi?id=67301
[2]: https://gerrit.wikimedia.org/r/#/c/130093/
--
Brad Jorsch (Anomie)
Software Engineer
Wikimedia Foundation
_______________________________________________
Mediawiki-api-announce mailing list
Mediawiki-api-announce(a)lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce
Hi, All,
I found in some of the UPLOAD update, there is no page id:
<rc type="log" ns="6" title="File:Lucian A. Sperta- Nunez.jpg" rcid="
114549183" pageid="0" revid="0" old_revid="0" user="Azarel63"oldlen="0"
newlen="0" timestamp="2014-01-05T11:09:38Z" comment="User created page with
UploadWizard" logid="77242320" logtype="upload"logaction="upload" img_sha1="
sf9t03wg27tl73nnde3jzfuxncefux9" img_timestamp="2014-01-05T11:09:36Z"/>
<rc type="log" ns="6" title="File:Gingerbread spices (annotated).jpg" rcid="
114549185" pageid="30485540" revid="0" old_revid="0"user="SKopp" oldlen="0"
newlen="0" timestamp="2014-01-05T11:09:37Z" comment="User created page with
UploadWizard" logid="77242318"logtype="upload" logaction="upload" img_sha1="
q84abqjr2n4bmn7o6j4uovpl5ufs2gq" img_timestamp="2014-01-05T11:09:37Z"/>
The first one has no page id but the second one has.
Does anybody can tell me the differences?
Thanks,
Ethan Liu
With Gerrit change 174200,[1] an HTTP header "Api-User-Agent" header will
be recognized for logging from the API. This should benefit clients using
XMLHttpRequest where the normal User-Agent header is locked down by the
browser. The logged agent will be the concatenation of Api-User-Agent and
the browser's User-Agent header.
This should come in handy once the ApiFeatureUsage extension[2][3] is
reviewed and deployed.
The new header will be recognized starting with 1.25wmf10, see
https://www.mediawiki.org/wiki/MediaWiki_1.25/Roadmap for the schedule. It
will be ignored for wikis still on 1.25wmf8 or 1.25wmf9, so feel free to
upgrade any scripts immediately. Bots and other clients that have full
control over the User-Agent header should continue to use that header
exclusively.
[1]: https://gerrit.wikimedia.org/r/#/c/174200/
[2]: https://www.mediawiki.org/wiki/Extension:ApiFeatureUsage
[3]:
https://www.mediawiki.org/wiki/API/Architecture_work/Planning#Deprecated_AP…
--
Brad Jorsch (Anomie)
Software Engineer
Wikimedia Foundation
_______________________________________________
Mediawiki-api-announce mailing list
Mediawiki-api-announce(a)lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce
Per architecture review[1], several API output formats will be removed from
MediaWiki:
* wddx and dump - in 6 months (around May 12, 2015)
* yaml, txt and dbg - in 1 year (around November 12, 2015)
They are already deprecated which means that every request made with them
receives a warning about deprecation. So on aforementioned dates, these
formats will be gone from WMF sites and the removals will be part of next
MediaWiki releases (presumably, 1.26 and 1.27). After that, only 3 formats
will be left: json, xml and php. Ideally, we would really love to have only
json, but currently there are no plans of doing it any time soon.
== Migration guide ==
The preferred format for using with MediaWiki API is JSON. The easiest way
to migrate would be:
* "YAML" as used by the API has actually been JSON for years, so just
replace format=yaml with format=json and make sure that your code does not
barf at content-type set to application/json instead of application/yaml.
* WDDX is a type-aware format so the logical transition would be JSON.
* dump and txt were are "serialising" using the PHP functions that were
never supposed to return anything machine-readable; and while format=dbg is
kinda machine-readable, passing its output to PHP's exec() is not the way
of machine-readability any security-aware person would want :) For any of
these formats, just sticking with JSON would make your life much, much
easier. However, if you're relying on specifics of exported PHP state in
your PHP-based client, format=php might make sense for a quick switch.
----
[1]
https://tools.wmflabs.org/meetbot/wikimedia-office/2014/wikimedia-office.20…
--
Best regards,
Max Semenik ([[User:MaxSem]])
Bug 73321[1] pointed out that generator=search was incorrectly trying to
set the same "searchinfo" and other properties on the result that were set
by list=search.
Gerrit change 172794[2] removes this setting, so generator=search will no
longer provide 'searchinfo' or 'interwikisearchinfo' members in the result.
Interwiki titles from the generator will no longer populate an
'interwikisearch' result property, but will instead be included in the
generated titles and thus (for action=query) will populate the 'interwiki'
property.
This change should be deployed to WMF wikis with 1.25wmf9, see
https://www.mediawiki.org/wiki/MediaWiki_1.25/Roadmap for the schedule.
[1]: https://bugzilla.wikimedia.org/show_bug.cgi?id=73321
[2]: https://gerrit.wikimedia.org/r/#/c/172794/
--
Brad Jorsch (Anomie)
Software Engineer
Wikimedia Foundation
_______________________________________________
Mediawiki-api-announce mailing list
Mediawiki-api-announce(a)lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce
The ApiQueryDeletedrevs module has issues: since it's a list module rather
than a prop module, it isn't handled correctly by the simplified
continuation, it doesn't support input of specific revids, and so on.
Gerrit change 168646[1] deprecates list=deletedrevs in favor of two new
modules:
* list=alldeletedrevisions will query the deleted revisions in a namespace
and/or for a user.
* prop=deletedrevisions will work like prop=revisions, querying deleted
revisions for a page, or specific revisions requested using action=query's
revids parameter.
For the latter to work properly, the revids parameter will now recognize
deleted revision IDs as valid if the querying user has the 'deletedhistory'
user right; before this change deleted revision IDs were treated as
non-existent.
These changes should be deployed to WMF wikis with 1.25wmf7, see
https://www.mediawiki.org/wiki/MediaWiki_1.25/Roadmap for the schedule.
At some point in the future, limited information from the archive table may
be made available to all users, as is already done on Tool Labs.[2] If that
happens, recognition of deleted revision IDs as valid for the revids
parameter will likely be extended to all users.
[1]: https://gerrit.wikimedia.org/r/#/c/168646/
[2]: https://bugzilla.wikimedia.org/show_bug.cgi?id=49088
--
Brad Jorsch (Anomie)
Software Engineer
Wikimedia Foundation
_______________________________________________
Mediawiki-api-announce mailing list
Mediawiki-api-announce(a)lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce