[Mediawiki-l] Database Errors after upgrade to 1.11 - no shell access

The Gadget Doctor mediawiki at thegadgetdoctor.com
Tue Jan 22 07:28:02 UTC 2008

After upgrading from 1.10 to 1.11 on certain of my pages I now get the
following error. The wiki image loads and nothing else.

I have worked out that on some of the pages there is a problem with the DPL
extension because when I turn this off the pages load. It is not all calls
to DPL but only some however and I can't see the pattern.

There are some pages, however, that refuse to load with this extension
turned off or on.

Unfortunately I'm on a shared host and don't have command line access. I've
tried to get phpshell working but that too will not work. Is there any
maintenance I can do on the database without shell?

Any help really appreciated (and I think I've realised that when I take this
site live it will be from a either a dedicated or virtual host that gives
shell access).

Database error A database query syntax error has occurred. This may indicate
a bug in the software. The last attempted database query was:

(SQL query hidden)

from within function "LocalFile::loadFromDB". MySQL returned error "1054:
Unknown column 'img_sha1' in 'field list' (localhost)".

More information about the MediaWiki-l mailing list