[Mediawiki-l] Fixing database after lost images

John Pye john at curioussymbols.com
Mon May 14 00:17:49 UTC 2007

Hi all,

I am having some trouble with our wiki at
http://ascendwiki.cheme.cmu.edu after a recent problem where a hard
drive problem caused us to lose the images in our wiki. We managed to
retrieve the database and I have reinstalled Mediawiki now (version
1.9.3) and some images I have put back into place in the wiki images
folder (/var/www/wiki/images/X/XX/whatever.png), but it is becoming
clear that all is not as it should be.

The first problem is that some of the images that I have replaced (from
files from other sources pre-wiki) in the above folders do appear in the
wiki, but do not appear to be thumbnailing correctly -- the image show
with rough-looking resizing, not the usual nice smooth job that I take
it is done by imagemagick.

The second problem is that I can't make uploading work any more. I have
set everything up in LocalSettings.php and the folder permissions look
right. I have set the $wgHashedUploadDirectory also. The funny thing is
that when I use the upload page, the image appears to upload (the HTTP
request takes a few moments) but then it fails silently: I am returned
to the upload page again, with no error message, and no message shows up
in the Apache error log either.

I tried to run management/rebuildImages using php5 CLI but it fails with
a message about failing to connect to the database with user = root and
no password. I couldn't see where to set the password (I tried modifying
php.ini but that wasn't it). So I can't see how to run this script, either.

Any suggestions for all this would be much appreciated. I'm sure it must
be something fairly simple I've failed to do.


PS I notice that some upload issues have been addressed in the new 1.10
release. Could that be related?

More information about the MediaWiki-l mailing list