[Mediawiki-l] Error msgs in 1.9.0 + semediawiki prob

Robin Faichney robin at robinfaichney.org
Sun Jan 14 11:38:36 UTC 2007

I tried to install the SemanticMediaWiki extension v0.6 (current) on
1.9.0 and got the same symptom as I reported with a vanilla
installation of 1.8.2 in the thread Empty pages..., ie just HTML head
and body tags with no content.

Rob Church advised in that thread to try setting $wgDisableCounters =
true; so I tried that in this situation, despite the fact that what
that was intended to work-around was supposedly fixed in 1.9.0. But I
got a result: with that in place I got the error message:

Fatal error: Class 'SMW_LanguageEn' not found in
C:\Domains\intersp.org\wwwroot\extensions\SemanticMediaWiki\includes\SMW_GlobalFunctions.php on line 136

I've gone over the semediawiki installation instructions several times
and I'm sure I've done everything correctly. I haven't yet looked for
any more appropriate forum to report this problem, but I thought that
people here might be interested in what it took to get that error
message. Here's the MW installation report again (for 1.8.2), let me
know if any other info would help:

PHP 5.1.6 installed
Found database drivers for: MySQL 
Warning: PHP's register_globals option is enabled. Disable it if you can. 
MediaWiki will work, but your server is more exposed to PHP-based security vulnerabilities. 
PHP server API is cgi-fcgi; using ugly URLs (index.php?title=Page_Title) 
Have XML / Latin1-UTF-8 conversion support. 
PHP is configured with no memory_limit. 
Have zlib support; enabling output compression. 
Couldn't find Turck MMCache, eAccelerator or APC. Object caching functions cannot be used.
GNU diff3 not found.
Found GD graphics library built-in, image thumbnailing will be enabled if you enable uploads. 
Installation directory: C:\Domains\****
Script URI path: 
Environment checked. You can install MediaWiki. 
Warning: $wgSecretKey key is insecure, generated with mt_rand(). Consider changing it manually. 
Generating configuration file...

Database type: MySQL 
Loading class: DatabaseMysql
Attempting to connect to database server as ****...success.
Connected to 4.1.21-community-max-nt-log 
Database **** exists
Creating tables... using MySQL 4 table defs... done. 
Initializing data...
Created sysop account ****.
Initialising "MediaWiki" namespace for language code en... 
Done. Updated: 0, inserted: 1495, kept: 0. 
Creating LocalSettings.php...

Installation successful! Move the config/LocalSettings.php file into the parent directory, then
follow this link to your wiki.

Robin Faichney
The Invisible Eye on Consciousness

More information about the MediaWiki-l mailing list