[MediaWiki-l] MediaWiki 1.32 is End of Life

Jeffrey Walton noloader at gmail.com
Thu Jan 23 22:20:11 UTC 2020


On Thu, Jan 23, 2020 at 2:48 PM Sam Reed <reedy at wikimedia.org> wrote:
>
> As per the MediaWiki version life cycle [1], I would like to announce the
> formal end of life (EOL) of MediaWiki 1.32 as of tomorrow, Friday January
> 24, 2019.
>
> This means that MediaWiki 1.32 will no longer receive maintenance or
> security backports. It is therefore strongly discouraged that you continue
> to use it.
>
> It is recommended to upgrade to MediaWiki 1.34 (due to become EOL in
> November 2020), or less preferably to MediaWiki 1.33 (due to become EOL in
> June 2020). The current Long Term Support (LTS) version of MediaWiki,
> MediaWiki 1.31, is older (and downgrading is not supported), though the
> next LTS (MediaWiki 1.35) is due to be released in June 2020, and will be
> supported until June 2023.
>
> MediaWiki 1.33 has the same supported PHP version of 7.0 (which is itself
> unsupported upstream), in case you need longer to upgrade your systems.
> MediaWiki 1.34 requires PHP 7.2.9 or later.

This puts some folks in a bad position.

The latest CentOS 7 does not support the versions of Python and PHP
required, even with Software Collections (SCL) enabled.

(In hindsight a Red Hat-based VM was a bad decision. It ships with
antique software, and SCL only provides old software. We need modern
software, and should have selected a Fedora or Ubuntu VM).

Jeff



More information about the MediaWiki-l mailing list