[MediaWiki-l] Please lower MySQL requirements in next release

Brian Wolff bawolff at gmail.com
Sun Dec 23 03:22:12 UTC 2018


On Sat, Dec 22, 2018 at 4:17 PM Jeffrey Walton <noloader at gmail.com> wrote:
>
> We use CentOS 7. Red Hat supplies antique software. It offers Media
> wiki 1.21, if I recall correctly. It is what it is. We had to take on
> maintenance of Mediawiki because we wanted to offer newer features
> users. Skins and extensions sometimes need something newer than what
> the platform provides.
>
> We've managed to update Apache, Python and PHP using SCL
> (https://wiki.centos.org/AdditionalResources/Repositories/SCL).
> However, we cannot get the MySQL update to work. We are stuck at MySQL
> 5.5.60. MySQL 5.5.60 was released April 2018.

MediaWiki requires MySQL 5.5.8 or greater. Well its not obvious, these
version numbers are not "decimal". i.e. 5.5.8 < 5.5.60, so 5.5.60
should work fine

If you encounter problems installing on mysql 5.5.60, it is a bug,
please tell us the errors you get (unless it was the error from your
other post).


> We can't upgrade to to MW 1.31 due to CentOS's MySQL. We tried to
> install MW 1.31 but maintenance/update.sh died when trying to update
> the database. We had to go to backup and restore the installation.
>
> It is not just CentOS. Other OSes, like Ubuntu 14 LTS, are boxing
> users. For example Ubuntu 14 provides MySQL 5.5.62
> (https://packages.ubuntu.com/search?keywords=mysql-server). MySQL
> 5.5.62 was released October 2018.
>
> Earlier I said "We've managed to update Apache, Python and PHP...".
> SCL does not offer Composer. Composer is an entirely new set of
> hardships. SCL probably does not offer Composer because dev tools have
> no business being on a production server. While you may think
> 'composer update' is easy, it took us a day and a half to work around
> all the problems and exceptions.

Composer is part of the build process. You only need it if installing
from git. If downloading the official tarball release you don't need
composer (Some skins & extensions like to use composer, but most
don't).

Generally you probably don't want composer on your production server.
Typically people (who are using a git install) would use composer to
generate the dependencies on a staging server and copy them over to
production. For example, Wikimedia uses a git repo of the composer
dependencies ( https://gerrit.wikimedia.org/g/mediawiki/vendor ) for
its production servers.

> Please consider lowering the MySQL requirements. Most helpful would be
to lower and freeze all requirements for the next 3 or 5 years.

Mysql 5.5.8 was released in 2010.

--
Brian



More information about the MediaWiki-l mailing list