[MediaWiki-l] Please lower MySQL requirements in next release

John phoenixoverride at gmail.com
Sat Dec 22 16:44:22 UTC 2018


I hate to be a downer (I’m normally the one complaining about said updates
breaking stuf$ but realistically major version bumps are needed. Ubuntu
14.04 is almost 5 years old and only has 4 more months of support. MySQL
5.5.x went EOL 3 years ago. You want to push support past that? CentOS to
my knowledge is the only major distro with issues supporting newer versions
of mediawiki. Mediawiki provides support for their LTS releases for 3
years, and releases them about every two years. Forcing mediawiki devs to
keep the same requirements for 6+ years is not reasonable. I will also note
that if CentOS is shipping with mediawiki 1.21 they are doing it wrong that
branch is 6+ years old.

On Sat, Dec 22, 2018 at 11:17 AM Jeffrey Walton <noloader at gmail.com> wrote:

> We use CentOS 7. Red Hat supplies antique software. It offers Media
> wiki 1.21, if I recall correctly. It is what it is. We had to take on
> maintenance of Mediawiki because we wanted to offer newer features
> users. Skins and extensions sometimes need something newer than what
> the platform provides.
>
> We've managed to update Apache, Python and PHP using SCL
> (https://wiki.centos.org/AdditionalResources/Repositories/SCL).
> However, we cannot get the MySQL update to work. We are stuck at MySQL
> 5.5.60. MySQL 5.5.60 was released April 2018.
>
> We can't upgrade to to MW 1.31 due to CentOS's MySQL. We tried to
> install MW 1.31 but maintenance/update.sh died when trying to update
> the database. We had to go to backup and restore the installation.
>
> It is not just CentOS. Other OSes, like Ubuntu 14 LTS, are boxing
> users. For example Ubuntu 14 provides MySQL 5.5.62
> (https://packages.ubuntu.com/search?keywords=mysql-server). MySQL
> 5.5.62 was released October 2018.
>
> Earlier I said "We've managed to update Apache, Python and PHP...".
> SCL does not offer Composer. Composer is an entirely new set of
> hardships. SCL probably does not offer Composer because dev tools have
> no business being on a production server. While you may think
> 'composer update' is easy, it took us a day and a half to work around
> all the problems and exceptions.
>
> Please consider lowering the MySQL requirements. Most helpful would be
> to lower and freeze all requirements for the next 3 or 5 years. A
> requirements freeze would allow us (and other users) to upgrade
> Mediawiki without the hassles and aggravations.
>
> Thanks in advance.
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>


More information about the MediaWiki-l mailing list