[MediaWiki-l] Moved site providers and now my URLs are /wiki/index.php?title=page

Richard legalize at xmission.com
Fri Sep 30 20:42:32 UTC 2016


In article <CA+oo+DVb5K4MgF4UJxJQpm7C=8eEx-emuLYiox3T82NGSVewdQ at mail.gmail.com>,
    Brian Wolff <bawolff at gmail.com> writes:

> Usually this means that mediawiki detects the new server as not supporting
> PATH INFO (usually deoends on the combination of server software and which
> php sapi is in use), so it cannot use the automatic short url setup. In
> such a case you usually need to setup rewrite rules to make it work,
> although you can also try adjusting $wgUsePathInfo to override the feature
> support autodetection if you think path info is really supported.

OK, this sounds like we're moving in the right direction as I don't
recall needing a rewrite rule for this before.  I will check with my
hosting provider.

I don't find $wgUsePathInfo in my LocalSettings.php; I'm currently on
MediaWiki 1.17.0, which I recognize is pretty ancient at this point.
(<http://terminals-wiki.org/wiki/index.php?title=Special:Version>)

This was one of the main motivations for changing hosting providers
so that I could get the software upgraded.  At this point, I've
migrated the content and that all seems to work OK except for the
form of the URL and one other issue, which I will post here separately.
-- 
"The Direct3D Graphics Pipeline" free book <http://tinyurl.com/d3d-pipeline>
            The Terminals Wiki <http://terminals-wiki.org>
     The Computer Graphics Museum <http://ComputerGraphicsMuseum.org>
  Legalize Adulthood! (my blog) <http://LegalizeAdulthood.wordpress.com>



More information about the MediaWiki-l mailing list