[MediaWiki-l] php update.php

Legault, Phillip [ITSUS] PLEGAULT at ITS.JNJ.COM
Thu Oct 29 15:39:30 UTC 2015


Yes I just tried this and my current php version is 5.4.40

php composer.phar update --lock
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - symfony/yaml v2.7.5 requires php >=5.3.9 -> your PHP version (5.3.3) or "config.platform.php" value does not satisfy that requirement.
    - symfony/yaml v2.7.5 requires php >=5.3.9 -> your PHP version (5.3.3) or "config.platform.php" value does not satisfy that requirement.
    - symfony/yaml v2.7.5 requires php >=5.3.9 -> your PHP version (5.3.3) or "config.platform.php" value does not satisfy that requirement.
    - Installation request for symfony/yaml == 2.7.5.0 -> satisfiable by symfony/yaml[v2.7.5].

[root at awsacrnva1027:/var/www/mediawiki/mw]#



-----Original Message-----
From: MediaWiki-l [mailto:mediawiki-l-bounces at lists.wikimedia.org] On Behalf Of John
Sent: Thursday, October 29, 2015 11:18 AM
To: MediaWiki announcements and site admin list
Subject: Re: [MediaWiki-l] php update.php

Do you have composer installed and updated?

On Thu, Oct 29, 2015 at 11:06 AM, Legault, Phillip [ITSUS] < PLEGAULT at its.jnj.com> wrote:

> I have a sandbox server where I test new releases of MW and SMW, when 
> everything is good I move them into my puppet environment to push 
> through development staging and production sites.
>
> I'm trying to push 1.25.3 to my development and when I run php 
> update.php I get the following
>
> #-> php maintenance/update.php
> MediaWiki 1.25.3 Updater
>
> mediawiki/semantic-media-wiki: 2.2.3 installed, ~2.2 required.
> mediawiki/semantic-result-formats: 2.3 installed, ~2.1  required.
> mediawiki/semantic-extra-special-properties: 1.3.1 installed, ~1.3 
> required.
> mediawiki/chameleon-skin: 1.1.4 installed, ~1.1 required.
> BorderCloud/SPARQL: not installed, * required.
> mediawiki/semantic-glossary: 1.1.2 installed, * required.
> mediawiki/lingo: 1.2.0 installed, * required.
> Error: your composer.lock file is not up to date, run "composer 
> update" to install newer dependencies 
> [root at development:/var/www/mediawiki/mw]#
>
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>
_______________________________________________
MediaWiki-l mailing list
To unsubscribe, go to:
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l


More information about the MediaWiki-l mailing list