[MediaWiki-l] My wiki stopped working

Daniel Friesen daniel at nadir-seen-fire.com
Mon Dec 28 14:16:56 UTC 2015


This sounds like you have a really old version of MediaWiki where that
class was still named 'Namespace' and not 'MWNamespace' and your version
of php was upgraded from a similarly ancient version to something above
5.3 that supports namespaces.

Upgrading MediaWiki should fix that problem.

~Daniel Friesen (Dantman, Nadir-Seen-Fire) [http://danielfriesen.name/]

On 2015-12-28 12:34 AM, Nomad of Norad wrote:
> Okay, a few weeks ago my wiki stopped loading.  The version I've got
> installed there is ancient, but it was working fine until one day it
> wasn't.  At first the page was giving me indefinite load-times,
> sometimes followed by a 502 error (depending on what web browser I
> tried it on).  I conversed with someone at my webspace provider and
> they rolled the stored page info back a couple days, and now I instead
> get:
>
> Parse error: syntax error, unexpected T_NAMESPACE, expecting T_STRING
> in
> /hermes/bosoraweb123/b65/ipw.joshua-w/public_html/wiki/includes/Namespace.php
> on line 46
>
>
> The web-address for my wiki is
> http://www.joshua-wopr.com/wiki/index.php?title=Main_Page
>
> I haven't touched the system in ages, and the tech help person seemed
> to think nothing had been altered (updated under the hood, say) at
> their end recently either.  Any idea what's wrong?
>
>
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l




More information about the MediaWiki-l mailing list