[MediaWiki-l] What PHP version do you use? (Was Re: MediaWiki-l Digest, Vol 147, Issue 3)

Chris Koerner nobelx at gmail.com
Wed Dec 16 16:01:52 UTC 2015


>Jan, and many others, have made a lot of valid comments on this
discussion. So why have they all been summarily dismissed with such...
complete lack of consideration?

The folks at the foundation are not copying files and running update.php
every time they update Wikipedia. :) They also have a focus on
foundation-sponsored projects and improving things where their constituents
are. Not a lot of Wiki* editors need a better MediaWiki installer.

I don't believe it is much of a priority - for the foundation or a
significant percentage of third-party administrators. Those who are
dedicated figure it out, new people have to have a lot of patience - or
they are turned away. Which is really sad, IMHO.

To that end, what can we do about it? Might I suggest we put together an
IdeaLab proposal <https://meta.wikimedia.org/wiki/Grants:IdeaLab> and see
if we can pool our own resources (attention and time) to figuring out what
it would take to improve this part of MediaWiki? See if there's enough
interest, identify opportunities for support (dev skills and money) and
take care of this.

I also suggest we make an appropriate and courteous amount of productive
noise in Phabricator
<https://phabricator.wikimedia.org/tag/mediawiki-installer/>. Add
experiences, feedback, and information to existing tasks related to the
installer. Add new ones for issues that have yet to be discovered.


Yours,
Chris Koerner
clkoerner.com


More information about the MediaWiki-l mailing list