[MediaWiki-l] What PHP version do you use?

Mickey Feldman mfeldman at vigil.com
Tue Dec 8 20:10:47 UTC 2015

I'm not sure that what you describe is what I've experienced.

We were (are still) running MW 1.21.1 with PHP 5.3.29. Our host upgraded 
to PHP 5.5 as default, and will soon discontinue support for PHP5.3.

MW 1.21 was advertised as "requires PHP5.3 or higher". I took that to 
mean PHP5.5 would not cause any problems.

As soon as the switchover happened, we had a screen full of error 
messages rather than wiki pages. I set the .htaccess to use PHP 5.3, and 
we now have a functioning wiki again.

However, I have no idea how long it will be before our host dumps PHP 
5.3 entirely, so we now have an upgrade forced on us, like it or not. 
This would not be a such a bad thing if the upgrade process were a 
little less fraught with uncertainty and room for errors, but it can 
sometimes be a bit nerve wracking.

I see that you mention LTS, and that 1.21 apparently slipped between the 
LTS versions. Too bad for us. My recollection is that we upgraded from 
1.19 to 1.21 for the same reason - PHP updated and the version we had no 
longer worked.

And it looks like we are (somewhat counter-intuitively) better off 
upgrading not to the current 1.26, but to 1.23, which is an LTS version.

> ----------------------------------------------------------------------
> Message: 1
> Date: Mon, 7 Dec 2015 17:27:14 -0700
> From: Bryan Davis <bd808 at wikimedia.org>
> To: MediaWiki announcements and site admin list
> 	<mediawiki-l at lists.wikimedia.org>
> Subject: Re: [MediaWiki-l] MediaWiki-l Digest, Vol 147, Issue 9
> Message-ID:
> 	<CAGrKmBLWn7t0jwrRhudkdTZQpXZjFo7MquMm1zbEQBhbQAOmSw at mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
> On Mon, Dec 7, 2015 at 3:39 PM, Mickey Feldman <mfeldman at vigil.com> wrote:
>> One more vote for this.
>> Upgrades have generally caused us much pain with little or no obvious
>> benefit. In our particular case, Mediawiki works well enough as is. Until
>> our host decides to update PHP forcing us to upgrade Mediawiki, and
>> discovering that it no longer works.
>> While there may be things we might like improved, we can't afford to
>> dedicate a full time Wikimedia guru to becoming expert in the hidden corners
>> of the code and keeping up with every change that might have some unexpected
>> side effect.
>> I realize that some of the changes are security fixes, and a Good Thing, but
>> I suspect these are in the minority. Our wiki is not public, so we could
>> probably get away with being a bit more lax about that, but when Mediawiki
>> is suddenly no longer compatible with php version-whatever, we have no
>> choice but to upgrade.
> I've seen a couple of comments similar to this one that seem to have
> the causal chain reversed so I thought I would try to clarify.
> If and when MediaWiki updates its minimum required PHP version nothing
> will change for existing MediaWiki deployments. The change will only
> effect new MediaWiki releases. If you are happily running MediaWiki
> 1.23 or similar on your wiki nothing at all will change.
> If and when your hosting provider updates their installed PHP version
> nothing will change for existing MediaWiki deployments. PHP generally
> goes out if its way to maintain backwards compatibility with running
> software designed for older versions of the PHP runtime. In the few
> cases that there are backwards compatibility breaking changes it is
> very likely that MediaWiki has already been patched to deal with them
> unless you are running a version of MediaWiki that predates the
> initial release of the new PHP version your provider has upgraded to.
> In that case if you are running a supported LTS version of MediaWiki
> you should only need to upgrade to the latest point version. If you
> are running something older than a supported LTS release, yes you may
> have to upgrade.
> Bryan

M. Feldman
Vigil Health Solutions, Inc.
2102 - 4464 Markham Street
Victoria, BC
Canada V8Z 7X8
Tel: 250-383-6900

More information about the MediaWiki-l mailing list