[MediaWiki-l] problems upgrading to 1.24.0 from 1.19 installed by RPM on CentOS

Alain Williams addw at phcomp.co.uk
Fri Nov 28 10:55:58 UTC 2014


I want to upgrade so that I can offer visual editor.

CentOS 6.6, 64 bit, postgresql database, php 5.3.3

I followed the instructions and using a browser:

* go to wiki//mw-config/index.php, language is OK so I click CONTINUE

* next page I am prompted for the upgrade key that I copy/paste, CONTINUE

* Environmental checks. Other than a warning about 'older version of the ICU
  project's library' all is OK, CONTINUE

* Database settings, enter username/password, CONTINUE

* Name page. I enter wiki name & admin details, select 'Im bored', CONTINUE

* Install page, CONTINUE

* I get database error: Error: 42P07 ERROR: relation "mwuser" already exists 
  It appears to be trying to do a fresh install rather than an upgrade. But it
  asked for the upgrade key earlier ?

As root at the command line I run & get:
    # php maintenance/update.php 
    MediaWiki 1.24.0 Updater

    DB connection error: No database connection

What am I doing that is wrong ?

-- 
Alain Williams
Linux/GNU Consultant - Mail systems, Web sites, Networking, Programmer, IT Lecturer.
+44 (0) 787 668 0256  http://www.phcomp.co.uk/
Parliament Hill Computers Ltd. Registration Information: http://www.phcomp.co.uk/contact.php
#include <std_disclaimer.h>



More information about the MediaWiki-l mailing list