[MediaWiki-l] Upload-problems in Xampp-environment

Chris Steipp csteipp at wikimedia.org
Wed Nov 12 20:33:44 UTC 2014


I haven't run SLES in a few years, but your issue might be apparmor
preventing writes in the web root. Is youre webserver listed when you
run aa-status?

On Tue, Nov 11, 2014 at 5:52 AM, Katharina Wolkwitz <wolkwitz at fh-swf.de> wrote:
> Hello everybody,
>
> I'm running my mediawiki-installation in a Xampp-environment  on a
> SLES11SP3-server, and since upgrading to version 1.23.6 I cannot get the
> file-upload to work again.
>
> So far I'ver tried the following:
>
> Settings in LocalSettings.php
>
> $wgEnableUploads = true;
> #$wgUploadPath    = "/_kate/test/images";
> $wgUploadPath        = "$wgScriptPath/images";
> $wgFileExtensions = array('dat', 'png', 'gif', 'jpg', 'jpeg', 'pdf');
> $wgCheckFileExtensions = true;
> $wgVerifyMimeType = false;
> $wgAllowExternalImages = true;
>
> wiki-t00:/opt/lampp/htdocs/_fhbwiki # chmod -R 0777 images
> wiki-t00:/opt/lampp/htdocs/_fhbwiki # chown -R wwwrun:www images
>
> But nothing changes the error-message I get (with minute difference in the
> goal-directory):
>
> Das Verzeichnis "mwstore://local-backend/local-public/f/f6" konnte nicht
> angelegt werden.
>
> Only if I add the following line in the LocalSettings.php-File:
>
> ## If you want to use image uploads under safe mode,
> ## create the directories images/archive, images/thumb and
> ## images/temp, and make them all writable. Then uncomment
> ## this, if it's not already uncommented:
> $wgHashedUploadDirectory = false;
>
> The error-message changes slightly to:
>
> Das Verzeichnis "mwstore://local-backend/local-public" konnte nicht angelegt werden
>
> In my former installation I didn't need to change the owner:group of the
> images-directory at all - there the directory belonged to the same owner:group
> as the rest of the mediawiki-directory and the upload worked fine with the
> 777-rights on the images-directory.
>
> I've found the following link
> https://www.mediawiki.org/wiki/Manual:Configuring_file_uploads#Check_directory_security
> and the hint to using the www-data user:group but on my server there is _no_
> such user:group.
> Would I need to add them in order to make the file-upload work?
>
> Kate
>
> _______________________________________________
> MediaWiki-l mailing list
> To unsubscribe, go to:
> https://lists.wikimedia.org/mailman/listinfo/mediawiki-l



More information about the MediaWiki-l mailing list