[Mediawiki-l] Issues with wikitable in 1.19

Stip stipen.treublatt at gmx.net
Thu May 31 17:43:58 UTC 2012


Am 31.05.2012 19:27, schrieb Platonides:
> Different specificity? What instructions are you using? 
> MediaWiki:Common.css *is* being loaded later. You can try debug the 
> page declarations with any CSS inspector tool. You may want to add 
> ?debug=true to the url to skip the css minification, though.
Thanks for the reply. :)
Unfortunately we all are css-noobs, so all we do is C&P and then 
changing it according to what we need... which might be the problem.

The code used at the moment is:

/* Wikitable */
table.wikitable {
     margin: 1em 1em 1em 5px;
     background-color: #ffffff;
     border: 1px #cccc99 solid;
     empty-cells:show;
     font-size: 95%;
}

table.wikitable>  tr>  th
table.wikitable>  tr>  td
table.wikitable>  *>  tr>  th
table.wikitable>  *>  tr>  td {
     border: 1px #cccc99 solid;
     padding: 0.2em;
}

table.wikitable>  tr>  th
table.wikitable>  *>  tr>  th {
     background-color: #ffec8b;
     text-align: center;
}

.wikitable th {
     background-color: #ffec8b ! important;
     text-align: center;
}

If we delete the last .wikitable th, the color of th is not the color we specify in table.wikitable>  tr>  th.
Same thing happens if we try it without the "important"-declaration. Also, the background-color #ffffff overwrites everything we
declare when using wikitable in articles.

Maybe you know a quick way to fix this? I will try using a css-inspection tool, thanks for that. :)

Greetings
Stip





More information about the MediaWiki-l mailing list