[Mediawiki-l] Fata error upgrading 1.17.0 to 1.18.2

Platonides Platonides at gmail.com
Sun Mar 25 15:30:19 UTC 2012


On 24/03/12 02:41, Boyandin Konstantin wrote:
> Hello,
> 
> Wgen trying to upgrade MediaWiki installation 1.17.0 to 1.18.2, the following happens when running ,aintenance/update.php:
> 
> Fatal error: Call to a member function getDbType() on a non-object in maintenance/doMaintenance.php on line 91
> (all upgrade steps are made as recommended in the supplied document).
> 
> The DB is garbled after that, I had to reverse both files and reload DB dump to have site back in working state.
> 
> Is the above a known problem? PHP version is 5.2.17.

No. It should have worked flawlessly.
Is any of your extensions changing $maintenance in their script? That
would explain what you're seeing.
What are your extensions? You could try disabling them and then run
update.php after enabling them again.





More information about the MediaWiki-l mailing list