[Mediawiki-l] upgrading to Mediawiki 1.17.0

Malka Cymbalista malki.cymbalista at weizmann.ac.il
Wed Sep 14 09:31:43 UTC 2011


 We are currently running Mediawiki 1.13.3 on a Linux machine and we are trying to upgrade to Mediawiki 1.17.0.  Everything went well until we got to the stage of updating the database.  We ran the command
% php update.php
And got the following results:

MediaWiki 1.17.0 Updater
Going to run database updates for mediawiki
Depending on the size of your database this may take a while!
Abort with control-c in the next five seconds (skip this countdown with --quick) ... 0
...ipblocks table does not exist, skipping new field patch
...ipblocks table does not exist, skipping new field patch
Creating interwiki table...ok
Adding default interwiki definitions...done.
Fatal error: Call to a member function isMultipleKey() on a non-object in /usr/local/mediawiki-1.17.0/includes/installer/MysqlUpdater.php on line 249

Any suggestions on how to proceed will be appreciated.
Thanks

Malki Cymbalista
Webmaster, Weizmann Institute of Science
malki.cymbalista at weizmann.ac.il
Tel: 08-9343036



More information about the MediaWiki-l mailing list