[Mediawiki-l] Weird page capitalization issues on my wiki

Sullivan, James (NIH/CIT) [C] sullivan at mail.nih.gov
Mon Apr 25 14:13:01 UTC 2011


Svip is right, of course ... (my morning caffiene had not taken effect yet).  Apache should also not have anything to do with the capitalizations of the page names on the page.  If all extensions were removed/disabled then either something was left behind, such as a modification in the includes directory, or an extension has modified the database. Do pages created after disabling the extensions have this behavior?

A fresh install of mediawiki would help clear some of this up.  If a fresh install does not have this behavior, then your Mediawiki or the database has been modified, most likely by an extension. 

As for whether its MySQL I don't see how since Mediawiki, or the extensions, control what goes in and what comes out.  

Back to the caffiene...

-Jim

-----Original Message-----
From: Svip [mailto:svippy at gmail.com] 
Sent: Monday, April 25, 2011 9:46 AM
To: MediaWiki announcements and site admin list
Subject: Re: [Mediawiki-l] Weird page capitalization issues on my wiki

On 25 April 2011 15:24, Sullivan, James (NIH/CIT) [C]
<sullivan at mail.nih.gov> wrote:

> I agree.  If you disabled all extensions (make sure you also changed back any Mediawiki files
> you may have modified due to a requirement of an extension), then its not a Mediawiki problem
> and most likely an Apache configuration issue.  You also might want to install a fresh Mediawiki
> instance so you can see if you get this behavior "out of the box" with Mediawiki.  If you do then
> that also points to Apache.  I'm not an Apache expert though, so have no idea what type of
> Apache configuration might cause this.

What?  How is this in any way an Apache issue?  Apache tells MediaWiki
the correct title, and MediaWiki somehow decides to respond with the
title being a-okay.

If it was an Apache issue, then why does MediaWiki think that the page
title is BIOWIKI here[1]?  It even takes the effort of linking to a
talk page that does not exist and colours the link red as it should.
Or does MediaWiki use LOWER() in its SQL, but use the $_GET['title']
for its links, rather than using the {{PAGENAME}} given by the table?

Also, you appear to have your version installed via subversion,[2] I
am certain r86390 is that different from the MediaWiki 1.16.4
available on mw.org (which does not have this bug).

[1] http://www.bioinformatics.org/wiki/BIOWIKI
[2] http://www.bioinformatics.org/wiki/Special:Version

_______________________________________________
MediaWiki-l mailing list
MediaWiki-l at lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-l


More information about the MediaWiki-l mailing list