[Mediawiki-l] 1.15.0 to 1.16.2 Upgrade problem

Platonides Platonides at gmail.com
Sun Apr 10 00:20:38 UTC 2011


Scott Thile wrote:
> Hello Folks,
> 
> I just attempted to upgrade my wiki ( http://pipedia.org ) from Mediawiki
> 1.15.0 to 1.16.2. After running the update I'm missing tables that 1.16.2 is
> looking for.
> 
> After uploading the new files I first tried using the installer to run the
> update from the web. Initially it reported that the database was schema 4
> and it would not be able to update it to schema 5, but it looked like it
> updated tables anyway? Apparently not, or not all of them. I then re-ran the
> installer with the backwards compatibility option and still had issues so I
> ran the update.php script using SSH shell access. It ran without reporting
> any errors, but I'm still getting errors indicating the database didn't
> update correctly.
> 
> This is using  PHP 5.2.15 (cgi-fcgi) and MySQL: 5.1.52.
> 
> Do you think the issues are related to the schema 4 data base or did I botch
> things up trying to use the installer first?
> 
> Fortunately I've got a back up of the database and all my files pre-upgrade
> attempt.
> I
> 'd really appreciate any help in getting this straightened out.
> 
> Thanks, Scott

What errors are you getting?
(eg. table foo not found)

What does update.php say?
(eg. table foo already exists)




More information about the MediaWiki-l mailing list