[Mediawiki-l] MediaWiki_SVN+Lucene-Search2_SVN+MWSearch_SVN = ZERO search results

agent dale cooper agentdcooper at gmail.com
Sun Jun 29 13:18:54 UTC 2008

I've been *trying* for *a very long time now* to implement Lucene-search
functionality on my MediaWiki site -- I've spent
Hours+Days+*Weeks*+*Months*troubleshooting this
*very issue* - I'm giving this one last effort, I am hoping *SOMEONE* will
be able to *help me*, otherwise I am thinking of moving away from MediaWiki
entirely (which would make me a very sad panda), and will painstakingly
import my MediaWiki into Drupal - then try out their neat sounding-module
called Drupal::Search_Attachments
I have put in over 1 year's worth of work into my MediaWiki-based wiki. I
truly *need* the solution that
<http://www.mediawiki.org/wiki/Extension:MWSearch>offers, but it has
been next to impossible for me to implement on my
Slackware server. Who knows, my trouble could very well be something I am
doing wrong! I'm human enough to admit that if it turns out to be the
This is why I come for assistance, I am thinking of posting to the MediaWiki
forums too, and linking here (hope that's OK), as I really, *really* want to
get Extension:Lucene-search<http://www.mediawiki.org/wiki/Extension:Lucene-search>
<http://www.mediawiki.org/wiki/Extension:MWSearch>working for me!

I have been trying to get
<http://www.mediawiki.org/wiki/Extension:MWSearch>working for over
6months now, and posted alot of my previous issues
* at the MediaWiki Lucene-Search Talk
but was unable to find any solutions to my problem. I even tried the
+Extension:MWSearch <http://www.mediawiki.org/wiki/Extension:MWSearch> setup
*to no avail*.

I am BACK, now with a *brand new computer* (well, it's actually
older-hardware, but newly formatted hard-drive), a freshly installed
*a very basic website* with some basic data input to test search
This is my current overall system setup;

   - Slackware 12.1 <http://www.slackware.com/>, on i686 Pentium III (Linux = Slackware 12.1's
   - MediaWiki: 1.13alpha
   - PHP: 5.2.6 (I used Slackware 12.1's PHP v5.2.6 update
   - MySQL: 5.0.51b
   - MediaWiki Extension(s): [Extension:lucene-search|MWSearch]] SVN
   and Lucene-search2<http://www.mediawiki.org/wiki/Extension:Lucene-search>
   + I downloaded & installed
mwdumper.jar<http://download.wikimedia.org/tools/mwdumper.jar>into the
Lucene-search2 "lib" dir = /usr/local/search/ls2
   - other tools:

I've gone over and over and *OVER* the directions per
Extension:MWSearch <http://www.mediawiki.org/wiki/Extension:MWSearch> pages,
I just cannot get this working properly on my box, now that I tried on a new
install with new everything, I am convinced this is not a problem on my end,
but I could be wrong --- I have documented EVERYTHING I did from install, to
now since I've been over this so many times, maybe by me posting my logs
here and what I did from begining to end, someone might "see something" I'm
missing?? Please HELP! =)

If you might be able to assist, but need more information from me, I've got
it for you = right


I am posting the link to where all my configs and logs are so that I don't
take up a ton of space on this message, hopefully someone can help me!

agentdcooper at gmail.com

More information about the MediaWiki-l mailing list