[Mediawiki-l] installing PHP5 exclusively for MediaWiki v1.9.1?

Jan 2036 at gmx.de
Mon Jan 29 23:58:15 UTC 2007


Hi Frederik,

i know that you can install php4/php5 parralell on a server (linux), so i guess, 
its possible under win as well.
Most Webhosters offer to choose php4 or php5 seperately for each subdomain.

But how to configure your webserver for php4/5, this topic should be discussed 
in a php-forum, e.g. http://www.phpfreaks.com/forums/ (or something else).

Best Regards,
Jan


Frederik Dohr schrieb:
> Hello all,
> 
> I've just tried to install MediaWiki v1.9.1 on one of our servers (Apache on Windows 2000). However, turns out this server is running PHP4 only at the moment.
> Thus I'll have to install PHP5 - but without endangering the PHP4-application already running on that server.
> 
> Is there an easy way to make PHP5 be used only for the .../HTDOCS/WIKI/ folder? (Renaming all wiki-related files to .PHP5 would probably cause a lot of trouble.)
> I believe the following thread might be what I'm looking for: http://lists.wikimedia.org/mailman/htdig/mediawiki-l/2006-July/013713.html
> Unfortunately, I don't fully understand those instructions - and I'd rather ask before messing with a live system...
> 
> PHPINFO() tells me that the MySQL "Client API version" is 3.23.49 - I guess that'll have to be upgraded as well!? But in contrast to PHP, MySQL is fully compatible with earlier version so it shouldn't break anything - right?
> 
> Any help would be greatly appreciated!
> 
> 
> -- F.
> 
> 
> PS: I hope this is a valid issue for this list. Unfortunately, I can't request help from our IT department, as this wiki project not "officially recognized" yet - and won't be until it's properly set up and ready to prove its worth (kind of a catch-22 there)...



More information about the MediaWiki-l mailing list