[Mediawiki-l] Database error upgradeing from 1.9 to 1.10

Rob Church robchur at gmail.com
Mon Aug 27 14:19:40 UTC 2007


On 27/08/07, George Kiraz <gkiraz at gorgiaspress.com> wrote:
> *       I ran the update.php script from the maintenance folder, but I received the following error: ADD rc_params blob NOT NULL default " failed with error code "ALTER command denied to user '<user name>'@'localhost' for table 'wikisyriaca_recentchanges' (localhost)

Well, the upgrade didn't complete because whichever user credentials
were in use weren't sufficient to alter the database.

The upgrader needs to be able to create and alter tables, indices,
etc. Create a user with appropriate permissions on the database
("GRANT ALL..." is fine) and update AdminSettings.php with this user's
credentials, then re-run the upgrader.


Rob Church



More information about the MediaWiki-l mailing list