[Mediawiki-l] Database error upgradeing from 1.9 to 1.10

George Kiraz gkiraz at gorgiaspress.com
Mon Aug 27 14:13:34 UTC 2007


I upgraded from 1.9 to 1.0 and now my site (http://www.bethmardutho.org/wikisyriaca) gives the following error:

Database error A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was: (SQL query hidden) from within function "Title::loadRestrictions". MySQL returned error "1146: Table 'wikidb.wikisyriaca_page_restrictions' doesn't exist (localhost)".

This is how I did my upgrade:

*	I made a copy of the live 1.9 version elsewhere 
*	I downloaded 1.10 and replaced the files of the live version with the 1.10 files. 
*	I copied AdminSettings.sample into AdminSettings.php and provided the login for the admin to the MySQL server. 
*	I ran the update.php script from the maintenance folder, but I received the following error: ADD rc_params blob NOT NULL default " failed with error code "ALTER command denied to user '<user name>'@'localhost' for table 'wikisyriaca_recentchanges' (localhost) 

Now if one goes to the iste (http://www.bethmardutho.org/wikisyriaca one gets:


Database error


A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was: 

(SQL query hidden)

from within function "Title::loadRestrictions". MySQL returned error "1146: Table 'wikidb.wikisyriaca_page_restrictions' doesn't exist (localhost)".

If anyone can help, I greatly appreciate it.

(P.S. I am not a PHP or MySQL guru!)

Thanks

George A. Kiraz

 

 

George A. Kiraz, M.St. (Oxon), M.Phil., Ph.D. (Cantab)
President Gorgias Press LLC
46 Orris Ave., Piscataway, NJ 08854
Tel. +1 732-699-0343
Fax +1 732-699-0342
http://www.gorgiaspress.com

ܐܬܟܬܒܬ ܐܓܪܬܢܝܬܐ ܗܕܐ ܒܝܕ ܚܕ ܕܘܝܐ ܘܚܛܝܐ ܕܠܐ ܫܘܐ ܕܢܕܟܪ ܫܡܗ ܐܠܐ ܡܛܠ ܨܠܘ̈ܬܐ ܘܒܥܘ̈ܬܐ ܕܩܪܘܝܐ܆ ܘܐܫܬܕܪܬ ܕܝܢ ܒܐܘܪܚܐ ܬܡܝܗܐ ܕܒܝܬ ܢܫܒܐ ܕܝܕܝܥ ܒܫܡ ܐܝܢܛܪܢܛ ܡ̣ܢ ܚܫܘܒܬܐ ܠܐܚܪܬܐ ܥܕܡܐ ܕܡܛܬ ܠܡܪܬܝܢܐ ܕܩܪܘܝܐ ܠܒܝܒܐ܆ ܘܒܐܝܢܐ ܐܬܪܐ ܥܒܪܬ ܐ̱ܢܫ ܠܐ ܝܕܥ܆ ܘܠܟܡܐ ܛܟܣ̈ܐ ܐܠܩܛܪ̈ܘܢܝܐ ܣܥܪܬ ܐܦ ܐ̱ܢܫ ܠܐ ܝܕܥ ܐܠܐ ܐܠܗܐ ܡܛܟܣܢܐ ܕܟܠܗܝܢ ܒܪ̈ܝܬܐ܀

  

** This communication is intended for the use of the recipient to whom it is addressed, and may contain confidential, personal, and/or privileged information. Please contact me immediately if you are not the intended recipient of this communication, and do not copy, distribute, or take action relying on it. Any communication received in error, or subsequent reply, should be deleted or destroyed.**

 



More information about the MediaWiki-l mailing list