[Mediawiki-l] moving mediawiki from one server to another plus virtual hosting

Jim Hu jimhu at tamu.edu
Tue Aug 21 15:31:12 UTC 2007


Did you adjust $wgScriptPath in LocalSetttings?  Remember that httpd  
document root is now the virtual host url.  If not that, I suspect  
some other path problem.  What do you mean by "not working" (On my  
server, the symptoms of $wgScriptPath problems are no skins and links  
going off into space, but not total php crash).  Have you checked the  
error logs?

Jim

On Aug 21, 2007, at 10:11 AM, Tim McGeary wrote:

> We are ready to move our mediawiki installation from a closed test
> server to a public production server.  I moved the entire  
> mediawiki-1.10
> directory to the new server, dumped the mysql db and then imported  
> it to
> the new server and added the same credentials to the db.
>
> But the wiki isn't working.  The only thing different between the two
> servers is that I'm using virtual hosting in the production  
> server.  So
> I'm wondering if there are httpd configurations that I haven't set in
> the Virtual Host configuration, and/or if there is something extra I
> need to do in addition to moving the mediawiki-1.10 directory and  
> DB to
> the new server.
>
> Any ideas?
>
> Thanks,
> Tim
>
> -- 
> Tim McGeary '99, '06G
> Senior Systems Specialist
> Lehigh University
> 610-758-4998
> tim.mcgeary at lehigh.edu
>
> _______________________________________________
> MediaWiki-l mailing list
> MediaWiki-l at lists.wikimedia.org
> http://lists.wikimedia.org/mailman/listinfo/mediawiki-l

=====================================
Jim Hu
Associate Professor
Dept. of Biochemistry and Biophysics
2128 TAMU
Texas A&M Univ.
College Station, TX 77843-2128
979-862-4054




More information about the MediaWiki-l mailing list