[Mediawiki-l] texvc

Maurizio Vitale maurizio.vitale at polymath-solutions.com
Wed Aug 8 02:01:23 UTC 2007


On Aug 7, 2007, at 3:34 PM, Bruno Goncalves wrote:

> Hi Maurizio,
>
> Things keep getting stranger and stranger... indeed, I'm not  
> getting any
> output from the texvc command, although the command itself seems to be
> correct:
>
> TeX: ./math/texvc '/var/www/html/wiki/images/tmp'
> '/var/www/html/wiki/images/tmp' '\sqrt{n^2}' 'UTF-8'
> TeX output:
>
> ---
> OutputPage::sendCacheControl: private caching;  **
> Request ended normally
> [bgoncalves at azrael wiki]$
>
> And if I run the command manually from the wiki directory, it works  
> fine:
>
> [bgoncalves at azrael wiki]$ pwd
> /var/www/html/wiki
> [bgoncalves at azrael wiki]$ ./math/texvc '/var/www/html/wiki/images/tmp'
> '/var/www/html/wiki/images/tmp' '\sqrt{n^2}' 'UTF-8'
> +7db31f1ef8b4b7d1bfcc94576455fa0a[bgoncalves at azrael wiki]$
>
> with the png image ending up in /var/www/html/wiki/images/tmp.
> Anything else you can think of?
>

Two things I'd still try:
	- I remember having read somewhere that one of the programs involved  
(possibly dvipng)
           is bad at reporting errors. Just to be sure, make the tmp  
and dest directory world writeable.
           If this fix the problem you have an issue w/ the user-id  
of the Apache server or the PHP
           interpreter (which I believe could be different depending  
on (F)CGI vs. mod_php, but here
           we're well outside my knowledge).

	- try to replace texvc with a shell script that echoes the result  
you get from the command line.
	  This way you can try to isolate the problem and know for sure  
whether it is a subprocess communication
           issue.

Other than that, I wouldn't know and you'll have to wait for others,
Best regards,

	Maurizio



More information about the MediaWiki-l mailing list