[Mediawiki-l] texvc

Maurizio Vitale maurizio.vitale at polymath-solutions.com
Tue Aug 7 16:29:26 UTC 2007


I've gone through some of this recently, so here's what I remember.

- you have to have dvipng installed, in addition to LaTex
- if texvc is not run you see a red box telling you so where you'd  
normally expect math equations to appear.
- by default Math.php runs ./math/texvc. You've to make sure that  
that file exists and is executable (and works).
   alternatively you can set $wgTexvc to the path of your system  
installed texvc
- and of course you have to set $wgUseTex to true

I think the above was all I had to do for having math on my hosted  
wiki. In my case the problem was that the
texvc I was uploaded was compiled for 64bit, while my shared server  
is a 32 bit machine, so even though
the executable was there in the right place it was not that helpful.

hth

	Maurizio

On Aug 7, 2007, at 12:12 PM, Bruno Goncalves wrote:

> Hi Dan,
>
> This is most likely what is covered in the readme file. Read the
>> troubleshooting section, you need to install AMS.
>>
>> http://svn.wikimedia.org/viewvc/mediawiki/trunk/phase3/math/README? 
>> view=markup
>
>
> I had tried following the trouble shooting suggestions... As far as  
> I can
> tell, everything should work.
> I have a full LaTeX installation, since that's what I normally use to
> typeset my papers.
> I can run texvc correctly as the web server's user, it can read and  
> write
> from /var/www/html/wiki/math and /var/www/html/wiki/images/tmp.  
> I've even
> tried to follow the "hacking" suggestions to see if I could figure  
> it out,
> but to no avail... Although I have noticed that when I run texvc by  
> hand it
> creates the aux, tex, etc... files (I've commented out the deletion  
> part of
> render.ml) and when it's run through wikimedia it doesn't. My guess  
> is that
> it isn't even calling texvc...
>
> Does any of the more experienced users have any suggestions?
> Thank you!
>
> Bruno
>
> ~Daniel Friesen(Dantman) of The Gaiapedia, Wikia Graphical  
> Entertainment
>> Project, and Wiki-Tools.com
>>
>> Bruno Goncalves wrote:
>>> Dear All,
>>>
>>> I've just finished installing mediawiki. Everything went fine,  
>>> except
>> for
>>> the TeX configuration...
>>> I've successfully compiled texvc and it runs correctly from the  
>>> command
>>> line. However, typing
>>>
>>> <math>\sqrt{n}</math>
>>>
>>> in a post, results in:
>>>
>>> *Failed to parse (unknown error): \sqrt{n}***
>>> I've set $wgTexvc, $wgUseTeX and $wgEnableUploads. Am I missing
>> something?
>>> Sincerely,
>>>
>>> Bruno
>>>
>>>
>>
>> _______________________________________________
>> MediaWiki-l mailing list
>> MediaWiki-l at lists.wikimedia.org
>> http://lists.wikimedia.org/mailman/listinfo/mediawiki-l
>>
>
>
>
> -- 
> *******************************************
> Bruno Miguel Tavares Goncalves, MS
> PhD Candidate
> Emory University
> Department of Physics
> Office No. N117-C
> 400 Dowman Drive
> Atlanta, Georgia 30322
> Homepage: www.bgoncalves.com
> Email: bgoncalves at gmail.com
> Phone: (404) 712-2441
> Fax:   (404) 727-0873
> *******************************************
> _______________________________________________
> MediaWiki-l mailing list
> MediaWiki-l at lists.wikimedia.org
> http://lists.wikimedia.org/mailman/listinfo/mediawiki-l




More information about the MediaWiki-l mailing list