[Mediawiki-l] moving contents

Ricardo Rodríguez webmaster at xen.net
Tue Oct 17 13:48:46 UTC 2006

>>> Rotem Liss rotemliss_net at fastmail.fm> 16/10/2006 18:58 >>
>I think that if you dump the 1.5.7 database and import it to the 1.8.2
>(drop the old database of 1.8.2 first, if exists), and then run "php
>maintenance/update.php" on 1.8.2. If you don't have LocalSettings.php
for 1.8.2,
>run the installation script instead of "php maintenance/update.php"
>importing the database. Dump all the important data, anyway, for any

Thanks, Rotem Liss,
I've tried both dump/import the 1.5.7 database into the 1.8.2 one and
directly moving contents by using Navicat for Windows. Both alternatives
through the same error message. phpMyAdmin is clearer and answer with
the following message:

SQL query: 
-- ----------------------------
-- Table structure for categorylinks
-- ----------------------------
CREATE TABLE `categorylinks` (`cl_from` int( 8 ) unsigned NOT NULL
default '0',
`cl_to` varchar( 255 ) CHARACTER SET utf8 COLLATE utf8_bin NOT NULL
default '',
`cl_sortkey` varchar( 86 ) CHARACTER SET utf8 COLLATE utf8_bin NOT NULL
default '',
`cl_timestamp` timestamp NOT NULL default CURRENT_TIMESTAMP ON UPDATE
UNIQUE KEY `cl_from` ( `cl_from` , `cl_to` ) ,
KEY `cl_sortkey` ( `cl_to` , `cl_sortkey` ) ,
KEY `cl_timestamp` ( `cl_to` , `cl_timestamp` ) 

MySQL said: #1071 - Specified key was too long; max key length is 1000

As expected, only the table Arquive, the first one just before
categorylinks, is created when I execute the script.

I'm guessing this message must be related with MySQL settings, but I am
far from being able to interpret this message. Please, could you/anybody
help me with this issue? Thanks!

All the best,


Ricardo Rodríguez
Your XEN ICT Team

More information about the MediaWiki-l mailing list