[Mediawiki-l] images won't show

Arjen Verweij arjen.verweij at gmail.com
Sat Oct 14 19:56:05 UTC 2006


Consensus on irc://freenode.net/mediawiki is that it is not possible (full
stop) to have [[Image: ]] tags browse images in a directory that haven't
been uploaded. This is rather annoying because I have a lot of images to
upload and just verbatim copying them would make my life a lot easier.

I guess Brion was trying to tell me this, but I didn't get it. Sorry.

Arjen


2006/10/14, Arjen Verweij <arjen.verweij at gmail.com>:
>
> For instance, if I alter:
>
> $wgLogo = "$wgStylePath/common/images/wiki.png"; to
>
> $wgLogo = "$wgStylePath/common/images/mediawiki.png";
>
>
> in LocalSettings.php, I get the image I'm trying to show with [[Image:
> mediawiki.png]]
>
>
>
> I'm really at a loss. :) Somewhere the module handling the [[Image: ]]
> tags is having problems I think...
>
>
>
> Arjen
> 2006/10/14, Arjen Verweij <arjen.verweij at gmail.com>:
> >
> > Brion,
> >
> > The code I am using is:
> >
> > [[Afbeelding:mediawiki.png]]
> >
> > because my locale is set to nl (Dutch). The English equivalent would be:
> > [[Image:mediawiki.png]]
> > I understand that putting in a URL after Image: won't work, I'm merely
> > trying to point out that the image is there and can be accessed. The line
> > shows up in red. [[Image:thisimagedoesntexist.png]] has the same effect.
> >
> >
> > Currently I'm trying to find out how I can debug this, it is as if my
> > mediawiki just can't find the path to the images directory. I haven't
> > changed anything in de configuration script, except changing InnoDB to
> > MyISAM, but I doubt this is the problem.
> >
> > Thanks for responding.
> >
> > Arjen
> >
> >
> >
> >
> > 2006/10/14, Brion Vibber <brion at pobox.com>:
> > >
> > > Arjen Verweij wrote:
> > > > I don't -want- to upload images, this particular images is in
> > > > wiki/skins/common/images/mediawiki.png - the message is just what
> > > jou get
> > > > when you click on the text.
> > > > When I enter http://url/to/wiki/skins/common/images/mediawiki.png in
> > > my
> > > > browser I I get to see the image just fine.
> > >
> > > That's not part of the in-wiki universe and so can't be referenced via
> > > [[Image:Mediawiki.png]].
> > >
> > > If for some reason you want to use it in the wiki, either enable
> > > uploads and
> > > upload it, or enable image URL references (possibly insecure and prone
> > > to abuse)
> > > and use the full URL.
> > >
> > > -- brion vibber (brion @ pobox.com)
> > >
> > >
> > >
> > > _______________________________________________
> > > MediaWiki-l mailing list
> > > MediaWiki-l at Wikimedia.org
> > > http://mail.wikipedia.org/mailman/listinfo/mediawiki-l
> > >
> > >
> > >
> > >
> >
>



More information about the MediaWiki-l mailing list