[Mediawiki-l] can't connect to database on the last step of the installation (osx 10.4.5)

Jiri Prazak bohemius at gmail.com
Fri Mar 3 16:17:17 UTC 2006

Hello all,

I'm installing MediaWiki on an OS X 10.4.5 system and am running into
a problem during the last step of the installation. Everything goes
well until

...already have interwiki table
...indexes seem up to 20031107 standards
Already have pagelinks; skipping old links table updates.
...image primary key already set.
The watchlist table is already set up for email notification.
...watchlist talk page rows already present
...user table does not contain old email authentication field.
Logging table has correct title encoding.
...page table already exists.
revision timestamp indexes already up to 2005-03-13
...rev_text_id already in place.
...page_namespace is already a full int (int(11)).
...ar_namespace is already a full int (int(11)).
...rc_namespace is already a full int (int(11)).
...wl_namespace is already a full int (int(11)).
...qc_namespace is already a full int (int(11)).
...log_namespace is already a full int (int(11)).
...already have pagelinks table.
No img_type field in image table; Good.
Already have unique user_name index.
...user_groups table already exists.
...user_groups is in current format.
Initialising "MediaWiki" namespace...

Sorry! This site is experiencing technical difficulties.

Try waiting a few minutes and reloading.

(Can't contact the database server: )

Tried reloading, tried dropping the database and recreating it but the
problem wont go away.  I looked around and folks mentioned recompile
of php but that was only when using new versions of MySQL.  Here are
versions of all the components

php 4.3.11
apache 1.3.33
mysql 4.0.21 (Complete MySQL)
mediawiki 1.5.7

Thanks for any insight you can shed on this issue.


More information about the MediaWiki-l mailing list