[Mediawiki-l] Problems with Character Encoding During Upgrade from 1.4.11 to 1.5.6

Patricia Barden webmaster at prwatch.org
Mon Feb 13 19:43:07 UTC 2006


I am doing a test upgrade of MediaWiki from v1.4.11 to v1.5.6. I've  
tried doing the upgrade several ways but am having some problems with  
special characters not converting properly - especially single  
quotation marks. I think that it must have something to do with  
MediaWiki changing the character encoding from ISO-8859-1 to UTF-8.

I first tried converting the character encoding using iconv from the  
terminal and then used the converted db in the upgrade. I did the  
rest of the upgrade from the web browser. This results in some  
strange stuff. For example, on the 1.4.11 site, on a page called  
'Devil's Weed', when I mouse over the link, I see that the single  
quote is translated as '%92'. When I mouse over the same link on the  
upgraded site, the single quote shows as 'â%3F%3F' and there are a  
lot of question marks in black triangles on the page where the single  
quotes should be appearing.

I tried doing the upgrade completely from the web browser in the  
hopes that the character conversion would happen automatically. This  
results in the character not being converted at all.

We're running php 5.1.1 and MySQL 4.1.15.

Any thoughts on how to get the special characters to show correctly  
in the upgraded version?


Tricia Barden

More information about the MediaWiki-l mailing list