[Mediawiki-l] Another user who can't install mediawiki

Pietro Speroni di Fenizio pietrosperoni at yahoo.com
Mon Apr 12 19:27:46 UTC 2004

Hello List.
My name is Pietro, and I have tried the whole day to
install mediawiki without success. The main problem is
that I don't have root access to the mysql.

I am being hosted by: http://www.pchighway.com/
Which have some cool caratteristics (or so it seem at
my inexperienced eyes):

PHP 4.3.3 (With Zend Optimizer 2.1.0)
MySQL 4.0.15 (2 databases)
OS Version FreeBSD 4.9 

So, in theory I should have the cards to make the
mediawiki work (which was the reason why I bought the
account in the first place!)

I'll explain all the relevant actions I did, so it is
easier for you to help me:
I downloaded mediawiki-1.2.3.tar.gz
Untarred, and unzipped in my computer.
ftp-ed in the directory /wiki (that is:
http://www.mysite.org/wiki )

I changed the chmod so that anybody could do
everything everywhere (is called trust), and I went to
the directory /wiki

You'll have to set the wiki up first!

MediaWiki 1.2.3 installation
Checking environment...
PHP 4.3.3 ok 
PHP server API is apache; ok, using pretty URLs
Have zlib support; enabling output compression. 
Found GD graphics library built-in, image thumbnailing
will be enabled if you enable uploads. 
Installation directory:
Script URI path: /wiki 

I complete the form, except for the sqlroot that I
don't have, and he does not like it. I go on the site
and I create the database, and the user, and the
SO now those things are created from outside.
I go back to my form...
and he stills asks me for the root password.
I try to give him my user password, but he trats it as
a random password (unpleasent after all the time I
needed to think that up!)

So I decide that I cannot use the install from the
web, and I go to the file.

And if before I had problem, now... wow!
I take the AdminSettings.sample and
LocalSetting.sample, change what I think is right:

$wgDBadminuser      = "pietrosperoni";
$wgDBadminpassword  = "..." ;)

Now, it seems that the problem comes here:
I tried both:
$IP = "/wiki";
$IP = "/wiki/includes";

And I got:


Warning: main(): open_basedir restriction in effect.
File(/wiki/includes/DefaultSettings.php) is not within
the allowed path(s):
on line 32

Warning: main(/wiki/includes/DefaultSettings.php):
failed to open stream: Operation not permitted in
on line 32

Warning: main(): Failed opening
'/wiki/includes/DefaultSettings.php' for inclusion
(include_path='.:/usr/lib/php:/usr/local/lib/php') in
on line 32

Warning: main(Setup.php): failed to open stream: No
such file or directory in
/usr/home/ourpieee/public_html/wiki/index.php on line

Warning: main(): Failed opening 'Setup.php' for
in /usr/home/ourpieee/public_html/wiki/index.php on
line 49

Fatal error: Call to undefined function: wfprofilein()
in /usr/home/ourpieee/public_html/wiki/index.php on
line 51


As soon as I entered in the wiki directory.
What should I do?

BTW, the frontend panel of the sql has all sort of
privileges that can be granted to users:

User: ourpieee_wikiuse Db: ourpieee_wikidb

I am very perplexed.

Sorry if it was long, but I thought you probably
needed all those data, to help me.
MANY thanks for who ever can answer.


Do you Yahoo!?
Yahoo! Tax Center - File online by April 15th

More information about the MediaWiki-l mailing list