today, I looked to a handful of unit and integration tests in MediaWIki
core, and I noticed we do not have a single namespace pattern for tests.
I would find it natural for integration tests (that are already in the
integration subfolder) to be in MediaWiki\Tests\Integration namespace, and
unit tests to be in MediaWiki\Tests\Unit.
This would allow those two kind of test to use "same" class name, and would
avoid hacks similar to
However, I'm not sure if this pattern I described in previous paragraphs is
the best one, and what is the best way of going forward in this case.
Thanks for any comments,